Cercasi esperto di formule excel. (1 Viewer)

Halverman

Nuovo forumer
Registrato
12 Agosto 2002
Messaggi
72
Località
Bassano del Grappa - VI
Ragazzi Ciao,

vediamo chi mi sa aiutare.
Dovrei implementare il software in excel per l’Halverman’s Consensus con delle nuove considerazioni “Vero” o “Falso” e non riesco ad ottenere il risultato esatto.
La formula da me inserita è la seguente e deve rispondere ai criteri sottoelencati:


=(SE(5<CO1982<6;1;SE(CO1982>=6;1,5;SE(4<CO1982<5;-1;SE(CO1982<=4;-1,5;0)))))

In sostanza mi deve risultare nella cella in questione: valore=1 se CO1982 è compreso tra 5 e 6; valore=1,5 se CO1982 è maggiore o uguale a 6; valore = -1 se Co1982 è compreso tra 4 e 5; valore = -1.5 se Co1982 è minore o uguale a 4.

Grazie per l’aiuto in quanto non riesco ad ottenere esattamente il risultato che mi serve.

Bye.
 

percefal

Utente Old Style
Registrato
4 Agosto 2002
Messaggi
7.814
Località
London
E' un problema che ho avuto un pò di tempo fa.
Mi pare di aver capito che si mettono troppe condizioni... per cui ho aggirato l'ostacolo dicendogli che se A1<0 allora VERO altrimenti A2
Su A2 impostavo se A2>=0 e <1 allora VERO altrimenti A3 e così via.

Non ricordo di preciso, al limite posso darti la mia soluzione domani mattina, in quanto ho il foglio sull'altro pc-
 
Registrato
7 Marzo 2002
Messaggi
8
Ciao Halverman, non ho capito una cosa, e cioè che valore vuoi che la formula restituisca quando la cella CO1982 contiene il valore esatto pari a 5

Se vuoi che restituisca il valore -1 allora la formula è

=SE(CO1982<=4;-1,5;(SE(CO1982<=5;-1;(SE(CO1982<6;1;1,5)))))

se vuoi che restituisca il valore 1 allora la formula è

=SE(CO1982<=4;-1,5;(SE(CO1982<5;-1;(SE(CO1982<6;1;1,5)))))

per il resto dovrebbe andare bene, comunque verifica, ciao e buon lavoro.
 

Halverman

Nuovo forumer
Registrato
12 Agosto 2002
Messaggi
72
Località
Bassano del Grappa - VI
Kurtinaitis ha scritto:
Ciao Halverman, non ho capito una cosa, e cioè che valore vuoi che la formula restituisca quando la cella CO1982 contiene il valore esatto pari a 5

Se vuoi che restituisca il valore -1 allora la formula è

=SE(CO1982<=4;-1,5;(SE(CO1982<=5;-1;(SE(CO1982<6;1;1,5)))))

se vuoi che restituisca il valore 1 allora la formula è

=SE(CO1982<=4;-1,5;(SE(CO1982<5;-1;(SE(CO1982<6;1;1,5)))))

per il resto dovrebbe andare bene, comunque verifica, ciao e buon lavoro.

Ciao Kurtinaitis,

Ti ringrazio per la gentile soffiata, tutto OK e grazie mille.

Bye.
 

tontolina

Forumer storico
Registrato
12 Marzo 2002
Messaggi
43.189
QUESTA FUNZIONA, GARANTITO!!!!!!! :D :D :D

=SE(E(CO1982<6;CO1982>5);1;SE(CO1982>=6;1,5;SE(E(CO1982<5;CO1982>4);-1;SE(CO1982<=4;-1,5;0))))


CIAO BOCCIASSA :-D
 
Registrato
17 Settembre 2010
Messaggi
1
:wall:Ciao Ragazzi ho un problemino a cui nessuno è stato in grado di rispondermi.
Ho bisogno di una formula che mi consenta di calcolare ogni singolo passaggio di miei canzoni che vanno in onda.
Devo calcolare,un solo passaggio al giorno (iniziando dal primo)
Il passaggio che avviene il secondo giorno lo considero purchè vada in onda dopo le 24 ore rispetto al passaggio del giorno precedente che ho considerato.
Vi inserisco un esempio sotto dove il calcolo l ho fatto manualmente.

Grazie in anticipo a tutti coloro in grado di risolvere il mio quesito fornendomi una formula

canzone data ora
io x sempre te 22/06/2009 20:08:02
io x sempre te 22/06/2009 17:50:17 1
io x sempre te 23/06/2009 19:08:51 1
io x sempre te 23/06/2009 17:20:44
io x sempre te 24/06/2009 20:37:19 1
io x sempre te 24/06/2009 18:45:30
io x sempre te 25/06/2009 21:04:45 1
io x sempre te 25/06/2009 16:15:28
io x sempre te 26/06/2009 13:59:05
io x sempre te 26/06/2009 19:51:12
 

Andrew66

Forumer attivo
Registrato
12 Ottobre 2009
Messaggi
935
:wall:Ciao Ragazzi ho un problemino a cui nessuno è stato in grado di rispondermi.
Ho bisogno di una formula che mi consenta di calcolare ogni singolo passaggio di miei canzoni che vanno in onda.
Devo calcolare,un solo passaggio al giorno (iniziando dal primo)
Il passaggio che avviene il secondo giorno lo considero purchè vada in onda dopo le 24 ore rispetto al passaggio del giorno precedente che ho considerato.
Vi inserisco un esempio sotto dove il calcolo l ho fatto manualmente.

Grazie in anticipo a tutti coloro in grado di risolvere il mio quesito fornendomi una formula

canzone data ora
io x sempre te 22/06/2009 20:08:02
io x sempre te 22/06/2009 17:50:17 1
io x sempre te 23/06/2009 19:08:51 1
io x sempre te 23/06/2009 17:20:44
io x sempre te 24/06/2009 20:37:19 1
io x sempre te 24/06/2009 18:45:30
io x sempre te 25/06/2009 21:04:45 1
io x sempre te 25/06/2009 16:15:28
io x sempre te 26/06/2009 13:59:05
io x sempre te 26/06/2009 19:51:12
.
 

Allegati

Users Who Are Viewing This Discussione (Users: 0, Guests: 1)

Alto